Is this really the version you are looking for? Kentico 9 documentation is no longer updated. Use the switch in the header to choose your Kentico version.

Recovering abandoned features, web parts and widgets

Kentico 9 stops supporting the Project management feature, as well as several other web parts and widgets that were present in previous versions. For example, the abandoned web parts include the Document library and Drop-down menu. See the complete list of abandoned web parts and widgets below.

This page describes how to deal with the abandoned features and components after performing the upgrade procedure. You either need to delete the corresponding components and data or recover the required code files.

Recovery packages

Download and use the following packages:

Recovering abandoned web parts and widgets

The upgrade procedure deletes all source files of the abandoned web parts, but their database records remain in the database. This ensures you can recover any of the removed web parts or widgets that you use on your site and make everything work as before the upgrade. You do not need to worry about losing these web parts from your site's pages and templates (their configurations is stored in the database).

Go through the list list of abandoned web parts and widgets and take the desired action for each component. Follow the steps in the sections below to either remove or recover the listed web parts or widgets.

Important: The abandoned web parts will not be considered in future Kentico versions and anything that you recover becomes your own custom code. You have access to all source files of the web parts and are free to modify them, but you need to maintain them yourself.

Recovering widgets

Start by determining whether your site actively uses the given widget:

  1. Open the Widgets application.
  2. Select the widget in the tree.
  3. View the Usage tab.

If you are NOT using the widget, delete the widget in the Widgets application.

If you are using the widget, you have the following options:

  • Create your own custom widget and delete the abandoned widget in the Widgets application.

Recovering web parts

Start by determining whether your site actively uses the given web part:

  1. Open the Web parts application.
  2. Select the web part in the tree.
  3. View the Usage tab.

If you are NOT using the web part, delete the web part in the Web parts application.

If you are using the web part, you have the following options:

  • Recover the web part – find the web part in the list of abandoned web parts and perform the following steps:
    1. Copy all related files from the recovery package into the CMS folder of your upgraded project (see the Web part files table column).
    2. If the web part requires web.config modifications (see the Additional modifications table column), add the specified directive into your project's web.config file.

    3. Web application projects only:
      1. Open your Kentico project in Visual Studio.
      2. Include the copied files into the CMSApp project (or CMSApp_AppCode for files in the Old_App_Code folder).
        1. Click Show all files at the top of the Solution Explorer.
        2. Locate the newly added files.
        3. Select the folders or files you wish to include one-by-one while holding the Ctrl key.
        4. Right-click one of the files and select Include in Project.

      3. Add any assembly references required by the web part (see the Additional modifications table column).
      4. Convert the added files to the web application format:
        • Visual Studio 2012: Right-click the project node (CMSApp) in the Solution Explorer and select Convert To Web Application.
        • Visual Studio 2013/2015: Select the project node (CMSApp) in the Solution Explorer, open the Project menu on the main toolbar and select Convert To Web Application.

      5. Build the affected projects (CMSApp, CMSApp_AppCode).

    – OR –

  • Replace the web part with a different set of Kentico web parts or create your own web part according to your needs. Delete the abandoned web part in the Web parts application.

 

On this page

Abandoned widgets

The following is a list of widgets that were removed in Kentico 9.

Display nameCode nameRemoved parent web part
Article listArticleList 
Article listArticleListEditors 
Articles RSS FeedArticlesRSSFeed 
Blog posts RSS feedBlogPostsRSSFeed 
Blog posts RSS feedBlogPostsRSSFeedEditors 
Building your on-line storeBuildingYourOnlineStore 
Document libraryDocumentLibraryDocument library
Drop-down menucmsmenu_1Drop-down menu
E-commerce settings checkerEcommerceSettingsCheckerE-commerce settings checker
News RSS FeedNewsRSSFeed 
Latest blog postsLatestBlogPostsEditors 
Latest blog postsLatestBlogPostsUsers 
Latest newsLatestNewsUsers 
Latest newsLatestNewsEditors 
Latest news for Corporate siteCorporateSite.LatestNewsEditors 
My projectsMyProjectsMy projects
Social bookmarkingSocialBookmarkingSocial bookmarking
Tasks assigned to meTasksAssignedToMeTasks assigned to me
Tasks owned by meTasksOwnedByMeTasks owned by me
Tree Menucmstreemenu_1Tree menu

Abandoned web parts

The following is a list of web parts and server controls that were removed in Kentico 9.

All recovery files except for the document library and project management web parts are located in the Web part and widget recovery package.

Note: Always copy the listed ascx files along with their corresponding code behind file (.ascx.cs).

Display nameCode name

Web part files

Additional modifications
Article listArticleListNoneInherited from the Repeater web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
Articles RSS feedArticlesRSSFeedNoneInherited from the CMS RSS feed web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
Attachments LightboxAttachmentsLightbox~/CMSWebParts/Viewers/Effects/jQueryFancyBox_files/ 
Attachment image galleryAttachmentImageGallery~/CMSWebParts/attachments/attachmentlightboxgallery.ascx 
Attachments CarouselAttachments Carousel~/CMSSripts/jquery/jquery-carousel.js 
Attachments Carousel 3DAttachmentsCarousel3D~/CMSSripts/jquery/jquery-cloud-carousel.js 
Blog posts RSS FeedBlogPostsRSSFeedNoneInherited from the CMS RSS feed web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
Drop-down menucmsmenu

~/CMSWebParts/Navigation/cmsmenu.ascx

~/CMSScripts/skmmenu.js

~/CMSScripts/skmmenuup.js

~/App_Code/skmMenu

~/App_Code/CMSControls/CMSMenu.cs

Web application projects

Copy the folders and files from ~/App_Code into the ~/Old_App_Code folder instead.

You then need to include these files into the CMSApp_AppCode project in Visual Studio.

Web application projects

  • CMSApp_AppCode project - add a reference to the System.Design assembly.
  • Web.config:
<pages ...>
	<controls>
		<add tagPrefix="cms" namespace="CMS.Controls" assembly="CMSAppAppCode" />
...

Web site projects

  • Web.config:
<pages ...>
	<controls>
		<add tagPrefix="cms" namespace="CMS.Controls" />
...
Document libraryDocumentLibraryAll files in the Document library recovery package.

On web site projects, restart the application after you copy the document library files – open the System application in the Kentico administration interface and click Restart application.

E-commerce settings checkerEcommerceSettingsChecker~/CMS/CMSWebParts/Ecommerce/EcommerceSettingsChecker.ascx 
Facebook activity feed FacebookActivityFeed~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookActivityFeed.ascx 
Facebook commentsFacebookComments ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookComments.ascx 
Facebook facepileFacebookFacepile ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookFacepile.ascx 
Facebook like boxFacebookLikeBox ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookLikeBox.ascx 
Facebook like buttonFacebookLikeButton ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookLikeButton.ascx 
Facebook recommendationsFacebookRecommendations ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookRecommendations.ascx 
Facebook send buttonFacebookSendButton ~/CMS/CMSWebParts/SocialMedia/Facebook/FacebookSendButton.ascx 
Google+ +1 buttonGooglePlusButton~/CMS/CMSWebParts/SocialMedia/GooglePlus/GooglePlusButton.ascx 
Google+ activity feedGooglePlusActivityFeed ~/CMS/CMSWebParts/SocialMedia/GooglePlus/GooglePlusActivityFeed.ascx 
Google+ badgeGooglePlusBadge ~/CMS/CMSWebParts/SocialMedia/GooglePlus/GooglePlusBadge.ascx 
Group document libraryGroupDocumentLibraryAll files in the Document library recovery package.On web site projects, restart the application after you copy the document library files – open the System application in the Kentico administration interface and click Restart application.
Language selectionlanguageselection

~/CMS/CMSWebParts/Localization/languageselection.ascx

~/App_Code/CMSPortalControls/WebParts/CMSAbstractLanguageWebPart.cs

Web application projects

Copy the folder and files from ~/App_Code into the ~/Old_App_Code folder instead.

You then need to include these files into the CMSApp_AppCode project in Visual Studio.

 
Language selection drop-downlanguageselectiondropdown

~/CMS/CMSWebParts/Localization/languageselectiondropdown.ascx

~/CMS/CMSWebParts/Localization/dd_arrow.gif

~/CMS/CMSWebParts/Localization/langselector.css

~/App_Code/CMSPortalControls/WebParts/CMSAbstractLanguageWebPart.cs

Web application projects

Copy the folder and files from ~/App_Code into the ~/Old_App_Code folder instead.

You then need to include these files into the CMSApp_AppCode project in Visual Studio.

 
Language selection with flagslanguageselectionwithflags

~/CMS/CMSWebParts/Localization/languageselectionwithflags.ascx

~/App_Code/CMSPortalControls/WebParts/CMSAbstractLanguageWebPart.cs

Web application projects

Copy the folder and files from ~/App_Code into the ~/Old_App_Code folder instead.

You then need to include these files into the CMSApp_AppCode project in Visual Studio.

 
Latest newsLatestNewsNoneInherited from the Repeater web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
Lightbox gallerylightbox

~/CMSWebParts/Viewers/Effects/lightbox.ascx

 
LinkedIn company insiderLinkedInCompanyInsider~/CMS/CMSWebParts/SocialMedia/LinkedIn/LinkedInCompanyInsider.ascx 
LinkedIn company profileLinkedInCompanyProfile ~/CMS/CMSWebParts/SocialMedia/LinkedIn/LinkedInCompanyProfile.ascx 
LinkedIn member profileLinkedInMemberProfile ~/CMS/CMSWebParts/SocialMedia/LinkedIn/LinkedInMemberProfile.ascx 
LinkedIn share buttonLinkedInShareButton~/CMS/CMSWebParts/SocialMedia/LinkedIn/LinkedInShareButton.ascx 
My projectsMyProjectsSee the Project management section. 
News listNewsListNoneInherited from the Repeater web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
News RSS FeedNewsRSSFeedNoneInherited from the CMS RSS feed web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
Product filterProductFilter

~/CMS/CMSModules/Ecommerce/Controls/Filters/ProductFilter.ascx

~/CMS/CMSWebParts/Ecommerce/Products/ProductFilter.ascx

 
Project listProjectListSee the Project management section. 
Project tasksProjectTasksSee the Project management section. 
Pinterest follow buttonPinterestFollowButton~/CMS/CMSWebParts/SocialMedia/Pinterest/PinterestFollowButton.ascx 
Pinterest pin it buttonPinterestPinItButton~/CMS/CMSWebParts/SocialMedia/Pinterest/PinterestPinItButton.ascx 
Repeater with CarouselRepeaterWithCarousel~/CMSSripts/jquery/jquery-carousel.js 
Repeater with LightboxRepeaterWithLightbox

~/CMSWebParts/Viewers/Effects/jQueryFancyBox_files/

 
Scrolling newsScrollingNewsNoneInherited from the Scrolling text web part. You do not need to recover any files, only decide whether to delete or keep the web part in the Web parts application.
SharePoint data source (obsolete)SharePointDataSource-

The obsolete SharePoint web parts were removed without any recovery options. The upgrade automatically deletes the web parts from the database and file system.

See the Integrating SharePoint chapter to learn how to display SharePoint content without the obsolete web parts.

SharePoint datagrid (obsolete)

SharePointDatagrid- 
SharePoint datalist (obsolete)SharePointDatalist- 

SharePoint repeater (obsolete)

SharePointDataViewer- 
Shopping cart previewShoppingCartMiniPreview~/CMS/CMSWebParts/Ecommerce/ShoppingCart/ShoppingCartMiniPreviewWebPart.ascx 
Social bookmarkingSocialBookmarking~/CMS/CMSWebParts/SocialMedia/SocialBookmarking.ascx 
Task info panelTaskInfoPanelSee the Project management section. 
Tasks assigned to meTasksAssignedToMeSee the Project management section. 
Tasks owned by meTasksOwnedByMeSee the Project management section. 
Tree menucmstreemenu

~/CMS/CMSWebparts/Navigation/cmstreemenu.ascx

~/CMSScripts/Controls/treemenu.js

~/App_Code/CMSControls/CMSTreeMenu.cs

Web application projects

Copy the folder and files from ~/App_Code into the ~/Old_App_Code folder instead.

You then need to include these files into the CMSApp_AppCode project in Visual Studio.

Web application projects

  • CMSApp_AppCode project - add a reference to the System.Design assembly.
  • Web.config:
<pages ...>
	<controls>
		<add tagPrefix="cms" namespace="CMS.Controls" assembly="CMSAppAppCode" />
...

Web site projects

  • Web.config:
<pages ...>
	<controls>
		<add tagPrefix="cms" namespace="CMS.Controls" />
...
Twitter feedTwitterFeed~/CMS/CMSWebParts/SocialMedia/Twitter/TwitterFeed.ascx 
Twitter follow buttonTwitterFollowButton ~/CMS/CMSWebParts/SocialMedia/Twitter/TwitterFollowButton.ascx 
Twitter tweet buttonTwitterTweetButton ~/CMS/CMSWebParts/SocialMedia/Twitter/TwitterTweetButton.ascx 

Project management

The Project management features are no longer supported in Kentico 9. Decide whether you wish to continue using project management after you perform the upgrade procedure.

Cleaning up project management data

If you do NOT use project management, download the Project management database cleanup package. The package contains SQL scripts that remove all data related to project management from your upgraded database.

Run the SQL scripts against your database in the following order:

  1. DB data removal.sql
  2. DB object removal.sql
  3. DB objects - alter procedure.sql

Recovering project management

If you wish to continue using project management after you upgrade, download the Project management recovery package and perform the following steps:

Note: You cannot recover project management for new Kentico 9 installations. The process only works for upgraded instances.

Important: Project management will not be considered in future Kentico versions. The recovery package gives you access to all project management files and source code and you are free to modify anything. However, the files become your own custom code that you need to maintain.

  1. Copy all folders from the recovery package into your Kentico project's CMS folder and merge all content.
  2. Open your Kentico solution in Visual Studio.
  3. Click File -> Add -> Existing Project and choose the CMS\ProjectManagementLibrary\ProjectManagement.csproj file.
  4. Unfold the References section of the ProjectManagement project and delete all invalid references.
  5. Add references to the required libraries in your Kentico project:

    1. Right-click the ProjectManagement project and select Add Reference.

    2. In the Reference Manager dialog, click Browse and navigate to the Lib folder of your Kentico web project.

    3. Add references to the following libraries:

      • CMS.Base.dll

      • CMS.Core.dll

      • CMS.DataEngine.dll

      • CMS.DocumentEngine.dll

      • CMS.EmailEngine.dll

      • CMS.EventLog.dll

      • CMS.Helpers.dll

      • CMS.LicenseProvider.dll

      • CMS.Localization.dll

      • CMS.MacroEngine.dll

      • CMS.Membership.dll

      • CMS.Modules.dll

      • CMS.Scheduler.dll

      • CMS.SiteProvider.dll

  6. Build the ProjectManagement project.

Web site Kentico projects - copy the resulting CMS.ProjectManagement.dll file into the Kentico project's CMS\bin folder. The built DLL is located in the ProjectManagementLibrary\bin\Debug (default) or Release folder.

Web application Kentico projects - you need to perform additional steps:

  1. Move the content from the copied CMS\App_Code folder into the CMS\Old_App_Code folder within your project files (you can then delete the App_Code folder).
  2. Include the copied folders and files into the Kentico projects:
    • CMSApp project:
      • App_Data\CMSModules\ProjectManagement\.*
      • App_Themes\Default\CMSModules\.*
      • CMSModules\Groups\Tools\ProjectManagement\.*
      • CMSModules\ProjectManagement\.*
      • CMSResources\CMS.ProjectManagement\.*
      • CMSWebParts\ProjectManagement\.*

    • CMSApp_AppCode project:
      • Old_App_Code\Pages\.*
      • Old_App_Code\ProjectManagement\.*

    1. Click Show all files at the top of the Solution Explorer.
    2. Locate the newly added files.
    3. Select the folders or files you wish to include one-by-one while holding the Ctrl key.
    4. Right-click one of the files and select Include in Project.

  3. Convert the added files to the web application format:
    1. Visual Studio 2012: Right-click the CMSApp project in the Solution Explorer and select Convert To Web Application.
    2. Visual Studio 2013/2015: Select the CMSApp project in the Solution Explorer, open the Project menu on the main toolbar and select Convert To Web Application.

  4. Add references from the CMSApp and CMSApp_AppCode projects to ProjectManagement:
    1. Right-click the project and select Add Reference.

    2. In the Reference Manager dialog, select ProjectManagement on the Projects -> Solution tab.

  5. Build the Kentico solution.

To finish the recovery (for both web application and web site projects), recreate a project management property that the upgrade deleted from the Group profile web part:

  1. Open the Kentico administration interface.
  2. Open the Web parts application.
  3. Select the Community -> Management -> Group profile web part in the tree.
  4. Switch to the Properties tab.
  5. Select the last property in the list and click New field.
  6. Set the following values for the property:
    • Field name: DisplayProjects
    • Data type: Boolean (Yes/No)
    • Required: Yes (selected)
    • Default value: No (not selected)
    • Field caption: Display projects tab
    • Form control: Check box

  7. Click Save.

You can now continue using project management features on your upgraded website (all related applications, web parts and widgets).